Project

General

Profile

Bug #43

Patterns have reversed colours

Added by Paul Kitching over 2 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
01/21/2020
Due date:
% Done:

0%

Estimated time:
Affected version:

Description

set pattern 3:set paint 1
ink 2
bar 40,100 to 60,120
set pattern 5:set paint 0
ink 6
bar 70,100 to 90,120

AMOS shows white "" and blue lines, not a white and blue background on them.


Files

0.9.2.6.png (770 Bytes) 0.9.2.6.png Baptiste Pillot, 01/22/2020 09:21 PM
0.9.3.1.png (730 Bytes) 0.9.3.1.png Baptiste Pillot, 01/22/2020 09:21 PM
0.9.2.6.png (5.9 KB) 0.9.2.6.png zoomed result (x15) Baptiste Pillot, 01/22/2020 09:29 PM
0.9.3.1.png (5.27 KB) 0.9.3.1.png zoomed result (x15) Baptiste Pillot, 01/22/2020 09:29 PM
Patterns.png (5.84 KB) Patterns.png Paul Kitching, 01/23/2020 05:52 PM
#1

Updated by Francois Lionet over 2 years ago

  • Status changed from New to Resolved

Fixed!

#2

Updated by Francois Lionet over 2 years ago

  • Target version set to 0.9.3
#3

Updated by Baptiste Pillot over 2 years ago

I am not an expert on AMOS patterns.

Here are the results, please confirm if it is fixed :

0.9.2.6 result :
zoomed result (x15)

0.9.3.1 result :
zoomed result (x15)

Please confirm if the new result is ok thanks to AMOS/AOZ specifications.

#5

Updated by Baptiste Pillot over 2 years ago

  • Status changed from Resolved to Feedback
#6

Updated by Paul Kitching over 2 years ago

There are quite a few problems with it, still.

I've attached a pic. On the left is AOZ, AMOS Pro on the right.

Here is the code:

cls 0
set paint 1
ink 2,4,5
bar 40,50 to 60,70
set pattern 3:set paint 1
bar 40,100 to 60,120
set pattern 5:set paint 0
ink 6,7,8
bar 70,100 to 90,120

The first pattern should be a solid fill, not pattern 4. It seems to be using the background ink colour as the pattern. The rest is correct.
The one below should be using ink colour 4 for the background (red). The foreground and border are correct (ink 2 and 5)
The one on the right should be a different pattern (it's using pattern 7), and be using colour 7 for the background. Ink 6 is correct for the foreground pattern colour, and the border is off, which is correct.

#7

Updated by Baptiste Pillot over 2 years ago

Thanks for this detailed example.

Confirmed still not working in version 0.9.3.2.

#8

Updated by Paul Kitching about 2 years ago

This is almost working. It actually IS, but is producing wrong results because of bug 145 (the default colours are wrong). Apart from that it is doing what it should be doing.

#9

Updated by David Baldwin 9 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF