Project

General

Profile

Bug #358

SCROLL leaves previous image when scrolling with transparancy

Added by Paul Kitching about 2 years ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
04/25/2020
Due date:
% Done:

0%

Estimated time:
3.00 h
Affected version:

Description

Normally the SCROLL command will scroll the defined area as specified by the DEF SCROLL command, without leaving any evidence of the previous frame before the scroll, but if you SET TRANSPARENT 0, then scroll, the previous pixels are still visible. This smears the scroll area across the screen.

#manifest: "pc"
#displayWidth:1920
#displayHeight:1080
#fullScreen:true
#splashScreen:false
#fps:false
set transparent 0
def scroll 1,20,20 to 100,400,0,5
ink 6
text 50,50,"test"
do
    scroll 1
    wait vbl
loop

Remove the SET TRANSPARENT 0 line to see how it should work.


Files

clipboard-202004251321-5phtk.png (2.77 KB) clipboard-202004251321-5phtk.png Paul Kitching, 04/25/2020 12:21 PM
#1

Updated by Paul Kitching almost 2 years ago

  • Affected version changed from 0.9.8.1 to 0.9.9.4
#2

Updated by Brian Flanagan over 1 year ago

  • Estimated time set to 3.00 h
  • Affected version changed from 0.9.9.4 to Beta RC2

Retested in Beta RC2. Still a problem.

#3

Updated by Paul Kitching over 1 year ago

  • Affected version changed from Beta RC2 to Beta 1

Updated affected version to Beta 1

#4

Updated by Paul Kitching about 1 year ago

  • Affected version changed from Beta 1 to 1.0.0 (B4)

Still a problem in Beta 4.

#5

Updated by Paul Kitching 8 months ago

  • Affected version changed from 1.0.0 (B4) to 1.0.0 (B10) u16

Still the same in Beta 10.

#6

Updated by Francois Lionet 8 months ago

  • Status changed from New to Resolved

Fixed! And other bugs too.

Also available in: Atom PDF